Loading...   Upload Image

Frage zu htaccess/mod_rewriteForum » Webzone » Allgemeines » Frage zu htaccess/mod_rewrite

Neues Thema verfassen Neues Thema

  • KatjanaUser ist offline
    Member


    Katjana

    Registriert: 31.10.2008
    Beitraege: 108

    13.06.2009 um 20:35 Uhr

    Huhu Leute,
    ich habe damal eine Frage.
    Also, ich versuche gerade mit einer .htaccess mod_rewrite zu verwenden, um meine seitenadressen so zu machen, wie hier. dazu habe ich das da eingetragen:

    RewriteEngine on
    RewriteRule ^(.*)$ $1.inc.php


    Allerdings bekommen ich dann folgene Fehlermeldung:

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@bplaced.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.


    Da dachte ich mir, okay dann schaust du mal, ob bplaced überhaupt das ganze unterstützt, aber finden in dieser "Liste" Php-Info tuen ich nichts darüber.

    Wäre wirklich lieb und nett, wenn mir jemand da helfen könnte...
    LG Katjana



  • PascalErorrUser ist offline
    Newbie


    PascalErorr

    Registriert: 21.12.2007
    Beitraege: 116

    13.06.2009 um 21:30 Uhr

    Bei Freehostern is das immer sone sache.. aber bei bplaced.net geht das nicht



    Wenn man sich dann beim Ministerium beschwert kommt warscheinlich nen DinA4 zettel zurück wo dick und fett "OWNED" draufsteht.
  • Lion11User ist offline
    Newbie


    Lion11

    Registriert: 03.12.2007
    Beitraege: 8

    13.06.2009 um 22:16 Uhr

    Hey,
    also ich benutze selber bei bplaced.net mod_rewrite.
    Bei mir klappt es ich weiß nur noch wieso es bei dir nicht geht?
    lg Lion



  • KatjanaUser ist offline
    Member


    Katjana

    Registriert: 31.10.2008
    Beitraege: 108

    13.06.2009 um 23:28 Uhr

    Hab ich vielleicht einen fehler in mod_rewrite drin, Lion?

    Aber danke schonmal, dass ihr mir geantwortet habt.



  • PascalErorrUser ist offline
    Newbie


    PascalErorr

    Registriert: 21.12.2007
    Beitraege: 116

    13.06.2009 um 23:48 Uhr

    Sry. wenn meine info falsch war :/ bei mir hat das auf Bplaced.net auch nie funktioniert

    mfg



    Wenn man sich dann beim Ministerium beschwert kommt warscheinlich nen DinA4 zettel zurück wo dick und fett "OWNED" draufsteht.
  • KatjanaUser ist offline
    Member


    Katjana

    Registriert: 31.10.2008
    Beitraege: 108

    14.06.2009 um 10:49 Uhr

    Macht ja nichts, aber irgendwie verwirrt es mich, wenn es bei dir nicht funktionierte und bei lion doch. ich doch seltsam...

    Edit 1:

    So, ich hab das jetzt mal so geschrieben:

    RewriteEngine on
    RewriteRule ^(.*).html$ .inc.php


    Und er zeigt mir nun die seiten an, aber wenn ich html wegnehme dann nicht, was muss ich also ändern, damit ich solche links wie hier bekommen, das also keine endung mehr dran ist?



    Der Beitrag wurde insgesamt 1 mal editiert, zuletzt 14.06.2009 um 12:44 Uhr ...
  • AliceUser ist offline
    Admin


    Alice

    Registriert: 14.12.2006
    Beitraege: 1059

    14.06.2009 um 20:28 Uhr

    So wie du es hattest greift die Regel auch immer auf die Ordner, das haut dir dann das ganze System zusammen, weil ein Aufruf eines Ordners so nicht mehr wirklich gegeben waere...

    Probier es mal hiermit:

    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule ^(.*)$ $1.inc.php



    ... { signatur } ...
  • KatjanaUser ist offline
    Member


    Katjana

    Registriert: 31.10.2008
    Beitraege: 108

    14.06.2009 um 21:41 Uhr

    Es funktioniert *freu*, dankeschön^^.



  • KatjanaUser ist offline
    Member


    Katjana

    Registriert: 31.10.2008
    Beitraege: 108

    15.06.2009 um 22:48 Uhr

    Sorry jetzt für den Doppelpost, aber jetzt muss ich euch nochmal mit einer Frage dazu quälen 8| .

    Also, ich hab jetzt mal auch so im Netzt rumgeschaut, aber irgendwie bin ich zu blöd etwas zu finden, was meine Frage beantwortet.
    Denn jetzt versuche ich die Seiten in mein Layout einzubinden, aber wie soll ich das denn machen, mit

    <?php include('header.php'); ?>
    oder kann man sowas auch in die htaccess-datei reinschreiben?

    Würde mich auf Antwort freuen.
    LG Katjana



  • AliceUser ist offline
    Admin


    Alice

    Registriert: 14.12.2006
    Beitraege: 1059

    18.06.2009 um 00:20 Uhr

    Mit der htaccess kannst du viele Dinge vollbringen, aber sowas funktioniert definitiv nicht.

    Du musst deinen header/footer schon in jede Datei einbinden, oder aber du drehst den Spies um bindest jeweils immer den Content ein, im Prinzip gehopft wie gesprungen, aber die htaccess kann dir da nicht wirklich helfen ;)

    Liebe Gruesse
    Alice



    ... { signatur } ...

[ 1 ] 2 » ... Letzte » Seite 1 von 2


Affiliates:   Blue-Graphics  •   Pat DG  •   The Seduction  •   Colorful Gfx  •   Gallery Yuri  •   Design Grafixx  •   Chibi Graphics  • Show all ...
designenlassen.de - Der Design-Marktplatz für Webdesign, Logo-Design, Flyerdesign u.v.m.        ALL-INKL.COM - Webhosting Server Hosting Domain Provider